Javascript.RU

Создать новую тему Ответ
 
Опции темы Искать в теме
  #1 (permalink)  
Старый 27.02.2018, 09:22
Интересующийся
Отправить личное сообщение для Xopc11 Посмотреть профиль Найти все сообщения от Xopc11
 
Регистрация: 01.07.2017
Сообщений: 16

Мое расширение "Не совместимо с Firefox Quantum"
Здравствуйте. Возникла такая проблема с FF:
Я загружаю свое расширение в Firefox Add-ons, но всегда получаю такую картину.



"Ваше расширение прошло все проверки, оно готово к скачиванию", но когда я открываю страницу с ним, мне пишет что оно не совместимо с Firefox Quantum.

И я вообще не понимаю как это исправить. Перерыл справку, но ничего конкретного не нашел... Дошло до того, что я уже скачал пример готового расширения и загрузил его. Но оно тоже не совместимо. При отладке расширений в самом браузере все работает без ошибок. Кто-то знает как загружать свои расширения после обновления FF? Заранее спасибо.

Последний раз редактировалось Xopc11, 27.02.2018 в 09:30.
Ответить с цитированием
  #2 (permalink)  
Старый 27.02.2018, 09:48
Профессор
Отправить личное сообщение для Dilettante_Pro Посмотреть профиль Найти все сообщения от Dilettante_Pro
 
Регистрация: 27.11.2015
Сообщений: 2,324

Xopc11,
Если у вас FF Quantum 57, то Расширения в FF 57
Ответить с цитированием
  #3 (permalink)  
Старый 27.02.2018, 12:11
Интересующийся
Отправить личное сообщение для Xopc11 Посмотреть профиль Найти все сообщения от Xopc11
 
Регистрация: 01.07.2017
Сообщений: 16

Да. И мне нужно, чтобы и мое расширение работало на 57+ версиях.
Ответить с цитированием
  #4 (permalink)  
Старый 27.02.2018, 15:38
Аватар для Aetae
Любитель
Отправить личное сообщение для Aetae Посмотреть профиль Найти все сообщения от Aetae
 
Регистрация: 02.01.2010
Сообщений: 5,098

Чтобы старое работало конкретно у вас - есть хаки для самого фурифокса, где-то на форме мазилы описаны.
Чтобы работало у всех - надо полностью переписать на новом API. Полностью, никаких половинчатых вариантов нет.
__________________
29375, 35
Ответить с цитированием
  #5 (permalink)  
Старый 27.02.2018, 23:49
Интересующийся
Отправить личное сообщение для Xopc11 Посмотреть профиль Найти все сообщения от Xopc11
 
Регистрация: 01.07.2017
Сообщений: 16

Сообщение от Aetae Посмотреть сообщение
Чтобы старое работало конкретно у вас - есть хаки для самого фурифокса, где-то на форме мазилы описаны.
Чтобы работало у всех - надо полностью переписать на новом API. Полностью, никаких половинчатых вариантов нет.
Я чего-то не понимаю? Что значит новый API? WebExtensions? Но я же на нем и пишу... Даже залил расширение, которое сам FF и предлагает для ознакомления. Вот это.
Но оно тоже не работает
Ответить с цитированием
  #6 (permalink)  
Старый 08.03.2018, 19:48
Интересующийся
Отправить личное сообщение для Xopc11 Посмотреть профиль Найти все сообщения от Xopc11
 
Регистрация: 01.07.2017
Сообщений: 16

Решил попробовать загрузить еще раз... И почему-то в этот раз выбрал распространение через сайт. По логике это значит, что расширение публикуется сразу для всеобщего пользования. Я всегда и выбирал 2й вариант, чтобы тестировать самому.



Быстро прошел модерацию и все спокойно работает и со всем совмещается.
Сверх разумы работают в FF...

Последний раз редактировалось Xopc11, 08.03.2018 в 19:53.
Ответить с цитированием
Ответ



Опции темы Искать в теме
Искать в теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Есть сайт https + мое расширение Chrome + Звук Signal Events/DOM/Window 2 12.05.2016 20:12
Требуется расширение для Firefox Keepad Работа 4 09.06.2014 00:02
Передача сообщения со страницы в расширение Firefox atrac Общие вопросы Javascript 0 24.12.2013 10:58
Расширение для Firefox Bebarr Swallow Общие вопросы Javascript 5 27.04.2012 20:24
Расширение для Firefox decadent Firefox/Mozilla 1 12.05.2011 10:16