Javascript-форум (https://javascript.ru/forum/)
-   Оффтопик (https://javascript.ru/forum/offtopic/)
-   -   Помогите красиво назвать переменную? (https://javascript.ru/forum/offtopic/37110-pomogite-krasivo-nazvat-peremennuyu.html)

devote 08.04.2013 16:22

Цитата:

Сообщение от FINoM
Как ты запомнил этот набор букв?

а ты думаешь автор свой ник забудет?

kobezzza 08.04.2013 16:25

Цитата:

Сообщение от megaupload (Сообщение 244852)
а про вытаскивания в осмысленные переменные это круто ил инет?)
или как вообще надо чтобы круто было? портфолио делаю

Не вижу в этом ничего криминального

megaupload 08.04.2013 16:32

Цитата:

Сообщение от devote
а ты думаешь автор свой ник забудет?

как тонко однако, немо

megaupload 08.04.2013 16:35

Кстати а вам понятны значения полей по их названиям?



То есть ДА, я забивай хуй на порядок слов, но образую логику, слова в названии поля как бы не являются словосоцитанием а скорее являются классами как у html элементов )

таким образом это облегчает поиск


в метода же когда я их вытаскиваю в переменные с осмысленными названиями , осмысленными ДЛЯ ТЕКУЩЕЙ функции)) норм?

вот так я их вытаскиваю, провожу с ними какие-то действия и засовываю обратно.



Как вам эта идея?

megaupload 08.04.2013 19:08

то есть это ДЛЯ ОБЬЕЕЕЕКТА это число movementSpeedPerMillisecond
а для НАС, в ЭТОЙ НАШЕЙ ФУНКЦИИ это число имеет ДРУГОЕ ЛОГИЧЕСКОЕ ЗНАЧЕНИЕ, и мы перекладываем его в коробку с НАЗВАНИЕМ отражающим это логическое значение. мы оперируем НЕ С ЗНАЧЕНИЯМИ, а с КОРОБКАМИ. и их название должно отражать их смысл.

То есть это для обьееекта это скорость движения единиц в миллисекунду, а ДЛЯ НАШЕЙ ФУНКЦИИ это просто скорость.

а потом обратно засовываем уже в "коробки" обьекта.

пнятна логика?
и как вам такой код стайл?

melky 08.04.2013 22:41

this.movementIsMoving
this.movementTimeStart
this.movementTimeFinish

--> Разделить и добавить в новый класс MovementInterpolator ?

тогда будет новый контекст для переменных и вообще меньше объём используемой оперативной памяти мозга объектами и связями между ними, которые в нейронах копошатся, когда код пишешь :)

(последнее реально, если грамотно разделить обязанности и связи)
this.movement.active
this.movement.start
this.movement.end


ваззап?

а насчёт имени переменной
Цитата:

Сообщение от megaupload
"Дата в которой если все пойдет как задумано и не появится препятствий которые нужно будет обходить обьект достигнет цели."

"позитивное время" ?
// всё ништяк и всем добра, если юнит дойдёт до конечной точки за это время
positiveTime


Цитата:

Сообщение от megaupload
то есть это ДЛЯ ОБЬЕЕЕЕКТА это число movementSpeedPerMillisecond
а для НАС, в ЭТОЙ НАШЕЙ ФУНКЦИИ это число имеет ДРУГОЕ ЛОГИЧЕСКОЕ ЗНАЧЕНИЕ, и мы перекладываем его в коробку с НАЗВАНИЕМ отражающим это логическое значение. мы оперируем НЕ С ЗНАЧЕНИЯМИ, а с КОРОБКАМИ. и их название должно отражать их смысл.

для «контекста», ты хотел сказать?

кстати,
Цитата:

Сообщение от megaupload
if (new Date() >= this.movementTimeFinish) {

зачем все так делают? зачем все создают новый объект, конвертируют его в число, и тут же скармливают сборщику мусора с добавлением тормозов?

почему никто не использует статический метод, который сразу возвращает число?
Date.now()

Gozar 08.04.2013 23:27

Цитата:

Сообщение от devote
а ты думаешь автор свой ник забудет?

Чё? :blink:

megaupload 08.04.2013 23:38

Цитата:

Сообщение от devote
а ты думаешь автор свой ник забудет?

ой не с того акка написал, Чё? :blink:

megaupload,
Я вот не пойму, ты или devote под дауна косите ?

megaupload 08.04.2013 23:39

ой

Gozar 08.04.2013 23:46

megaupload,
Не пойму, ты или devote под дауна косит?


Часовой пояс GMT +3, время: 02:07.