Javascript.RU

Создать новую тему Ответ
 
Опции темы Искать в теме
  #21 (permalink)  
Старый 08.10.2019, 12:24
Интересующийся
Отправить личное сообщение для alex_chz Посмотреть профиль Найти все сообщения от alex_chz
 
Регистрация: 08.10.2019
Сообщений: 14

Хз, где они там прописаны. Вот для тех кому интересно как переопределить базовые скрипты в джумле, прописав это в индексе шаблона
<?php
$doc = JFactory::getDocument();
$scr = '/media/jui/js/jquery.min.js';
$repl_scr = '//ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js';
$key = array_keys($doc->_scripts);
$value = array_values($doc->_scripts);
$key = str_replace($scr, $repl_scr, $key);
$doc->_scripts = array_combine($key, $value);
?>


То есть он заменил исходный jquery.min.js. Стал на его место. Но что в итоге, не х.. НЕ ЗАРАБОТАЛ. И в самой джумле если что с коробки подключен миграт, на 3 подключена версия 1.4.1, что вроде последняя.

Вообщем тупик становиться уже(
Ответить с цитированием
  #22 (permalink)  
Старый 08.10.2019, 12:29
Профессор
Отправить личное сообщение для laimas Посмотреть профиль Найти все сообщения от laimas
 
Регистрация: 14.01.2015
Сообщений: 10,865

Точно не помню, но до версии 2.0, фай миграции имеет версию 1.2, вроде бы так.
Если все нужные файлы подключены, но не работает, то уже нужно смотреть логи в отладчике браузера.
Ответить с цитированием
  #23 (permalink)  
Старый 08.10.2019, 12:30
Интересующийся
Отправить личное сообщение для alex_chz Посмотреть профиль Найти все сообщения от alex_chz
 
Регистрация: 08.10.2019
Сообщений: 14

Сообщение от laimas Посмотреть сообщение
Точно не помню, то до версии 2.0, фай миграции имеет версию 1.2.
Если все нужные файлы подключены, но не работает, то уже нужно смотреть логи в отладчике браузера.
Опа, щяс проверю и переопределю
Ответить с цитированием
  #24 (permalink)  
Старый 08.10.2019, 12:39
Интересующийся
Отправить личное сообщение для alex_chz Посмотреть профиль Найти все сообщения от alex_chz
 
Регистрация: 08.10.2019
Сообщений: 14

Не не пашет. Логи пишут вот что, в меню у меня подключается еще и библеотека 2.1.1. То есть конфилкта с джумловским скриптом нет, а с меню есть
Ответить с цитированием
  #25 (permalink)  
Старый 08.10.2019, 12:43
Интересующийся
Отправить личное сообщение для alex_chz Посмотреть профиль Найти все сообщения от alex_chz
 
Регистрация: 08.10.2019
Сообщений: 14

походу придется меня другое искать
Ответить с цитированием
Ответ



Опции темы Искать в теме
Искать в теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Как исправить конфликт в javascript? Marknsk Общие вопросы Javascript 6 23.09.2019 15:15
Как правильно организовать подключение скриптов? s24344 Общие вопросы Javascript 0 31.12.2018 10:53
Конфликт Скриптов Mikael86 Общие вопросы Javascript 0 01.05.2018 17:46
Конфликт скриптов tk.stas Общие вопросы Javascript 0 21.10.2016 13:54
Подскажите как найти конфликт скриптов (резкий скроллинг / моментальный) mxup Общие вопросы Javascript 1 20.07.2016 16:49