Javascript.RU

Создать новую тему Ответ
 
Опции темы Искать в теме
  #1 (permalink)  
Старый 11.04.2012, 15:54
Аватар для macdack
партизан, доктор
Отправить личное сообщение для macdack Посмотреть профиль Найти все сообщения от macdack
 
Регистрация: 29.06.2011
Сообщений: 221

актуальная версия JS
немного запутался в попытке погуглить вопрос

какая версия языка актуальна на данный момент и поддерживается всеми браузерами?
Ответить с цитированием
  #2 (permalink)  
Старый 11.04.2012, 16:20
Аватар для macdack
партизан, доктор
Отправить личное сообщение для macdack Посмотреть профиль Найти все сообщения от macdack
 
Регистрация: 29.06.2011
Сообщений: 221

1.8 поддерживается всеми браузерами?

имею в виду последние и предпоследние версии браузеров
Ответить с цитированием
  #3 (permalink)  
Старый 11.04.2012, 16:30
Аватар для B@rmaley.e><e
⊞ Развернуть
Отправить личное сообщение для B@rmaley.e><e Посмотреть профиль Найти все сообщения от B@rmaley.e><e
 
Регистрация: 11.01.2010
Сообщений: 1,810

JS —реализация ECMAScript от Mozilla.
Соответственно, не-Firefox'оподобные браузеры реализуют именно стандарт ECMAScript, а не изобретения Mozilla.

Последняя версия стандарта ECMA-262 — 5-ая (постепенно реализуется), до этого была 3-я (4-ую пропустили).
Ответить с цитированием
  #4 (permalink)  
Старый 11.04.2012, 16:37
Аватар для Раед
''
Отправить личное сообщение для Раед Посмотреть профиль Найти все сообщения от Раед
 
Регистрация: 11.12.2011
Сообщений: 636

Сообщение от macdack
не-Firefox'оподобные браузеры
можно поподробнее, какие к таким (не FF подобным) относяться?
Ответить с цитированием
  #5 (permalink)  
Старый 11.04.2012, 16:47
Аватар для B@rmaley.e><e
⊞ Развернуть
Отправить личное сообщение для B@rmaley.e><e Посмотреть профиль Найти все сообщения от B@rmaley.e><e
 
Регистрация: 11.01.2010
Сообщений: 1,810

Раед, Chromium, Opera, IE.
Ответить с цитированием
  #6 (permalink)  
Старый 11.04.2012, 16:51
Аватар для macdack
партизан, доктор
Отправить личное сообщение для macdack Посмотреть профиль Найти все сообщения от macdack
 
Регистрация: 29.06.2011
Сообщений: 221

Сообщение от B@rmaley.e><e Посмотреть сообщение
JS —реализация ECMAScript от Mozilla.
Соответственно, не-Firefox'оподобные браузеры реализуют именно стандарт ECMAScript, а не изобретения Mozilla.

Последняя версия стандарта ECMA-262 — 5-ая (постепенно реализуется), до этого была 3-я (4-ую пропустили).
вот и вы меня запутываете ))

мне надо понять какую версию поддерживают предпоследние версии всех браузеров - в нумерации типа 1.х и Ecma-262
Ответить с цитированием
  #7 (permalink)  
Старый 11.04.2012, 16:58
Аватар для B@rmaley.e><e
⊞ Развернуть
Отправить личное сообщение для B@rmaley.e><e Посмотреть профиль Найти все сообщения от B@rmaley.e><e
 
Регистрация: 11.01.2010
Сообщений: 1,810

Сообщение от macdack
мне надо понять какую версию поддерживают предпоследние версии всех браузеров - в нумерации типа 1.х и Ecma-262
1.5 и ECMA-262, edition 3
Что касается ECMA-262 edition 5, посмотрите на таблицу совместимости с ES5,
Ответить с цитированием
  #8 (permalink)  
Старый 11.04.2012, 18:47
sinistral
Посмотреть профиль Найти все сообщения от melky
 
Регистрация: 28.03.2011
Сообщений: 5,418

Сообщение от macdack Посмотреть сообщение
1.8 поддерживается всеми браузерами?

имею в виду последние и предпоследние версии браузеров
можно на месте проверять, какую версию держит браузер, используя устаревший атрибут "language" тега <script>
http://jsbin.com/iherov/2

Код:
FF 11.0           - 1.8
CH 18.0.1025.151  - 1
Konquerror 4.8.2  - 1

Последний раз редактировалось melky, 11.04.2012 в 23:09.
Ответить с цитированием
  #9 (permalink)  
Старый 11.04.2012, 19:08
Аватар для B@rmaley.e><e
⊞ Развернуть
Отправить личное сообщение для B@rmaley.e><e Посмотреть профиль Найти все сообщения от B@rmaley.e><e
 
Регистрация: 11.01.2010
Сообщений: 1,810

Сообщение от Maxmaxmахimus
хром 1.7
лолшто? New in JavaScript 1.7:
function fib() {
  var i = 0, j = 1;
  while (true) {
    yield i;
    var t = i;
    i = j;
    j += t;
  }
}

var g = fib();
for (var i = 0; i < 10; i++) {
  console.log(g.next());
}

Ну запустите это в хромиуме.
Сообщение от Maxmaxmахimus
можно ссылку на какой нибудь не мозиллаподобный браузер?
http://lmgtfy.com/?q=chromium
Сообщение от Maxmaxmахimus
и они поддерживают не ECMA а javascript
Да конечно.

Советую оставить свои предположения в стороне и оперировать лишь фактами. Впрочем, славу неадеквата Вы и так уже заслужили.

Сообщение от melky
можно на месте проверять, какую версию держит браузер, используя устаревший атрибут "language" тега <script>
http://jsbin.com/iherov
Цитата:
Javascript version 2 supported
Edit in jsbin.com
Отличный тест! Только вот что-то у меня простейший кусок ES4 кода
var age : int = 23;
падает с синтаксической ошибкой.
Ответить с цитированием
  #10 (permalink)  
Старый 11.04.2012, 23:08
sinistral
Посмотреть профиль Найти все сообщения от melky
 
Регистрация: 28.03.2011
Сообщений: 5,418

Сообщение от B@rmaley.e><e Посмотреть сообщение
Отличный тест!
хреновый тест. похоже, что таким обрабом можно делать только в файрфоксе. не знал
Ответить с цитированием
Ответ



Опции темы Искать в теме
Искать в теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Не получается вставить код js в HTML garmoni Элементы интерфейса 3 05.09.2013 04:56
Разное оформление для посетителей с JS и без fry2 Events/DOM/Window 13 03.02.2012 15:45
Картинка обрабатывается js 4yBaK Общие вопросы Javascript 10 11.09.2011 08:28
Не получается передать переменную из JS в PHP Lion_astana AJAX и COMET 2 23.11.2010 16:23
помогите задать переменную в js bsgroupua Общие вопросы Javascript 3 01.02.2010 17:28